User Portal Unavailable
Incident Report for Targetable
Resolved
This incident has been resolved.
Posted May 06, 2019 - 17:56 PDT
Update
We are continuing to investigate this issue.
Posted May 06, 2019 - 17:55 PDT
Investigating
Our User Portal may not be accessible for some users. We are currently investigating the issue. In the meantime if something is urgent, contact us through **support@herofi.com**
Posted May 06, 2019 - 17:50 PDT